Jump to content
Home
Forum
Join Us
What's New
Articles
Resources
About Us
Tapestry
mattkelly

IO Exception Connection failed, IO Exception

Recommended Posts

A lot of users have encountered this error so I've decided to create a dedicated topic for it so that I can refer people to it in the future.

 

This error message is displayed when the PRAMS launcher is unable to connect to the internet, this usually happens when it is checking for or downloading updates. There are various reasons why PRAMS fails to connect to the internet, which I list here in order of likelihood.

  • You are using a proxy server and PRAMS is not able to get past it. If you are using PRAMS in a school, nursery or other LA establishment it is likely that your internet connection is routed through a device called a proxy server. The purpose of the proxy server is to provide security to your network and speed up intertnet access. As of v2.1.8 PRAMS can automatically detect your proxy server configuration but sadly this doesn't always work. If this happens you need to go to the launcher's "Options" screen, select "Manually configure proxy server settings" and enter the correct details. These details can be obtained from whoever is responsible for your network. If your proxy sever required authentication PRAMS will ask you to enter a password when you click "ok" on the options screen, this password will be used to protect your authentication details and needs to be entered each time you start PRAMS.
  • Something is wrong with your internet connection or you are not connected to the internet. Please check that you are able to access the internet with your web browser.
  • PRAMS is being blocked by your firewall. There are many firewalls available so I can't explain how to deal with each one. You need to add PRAMS as an exception so that it is allowed through your firewall. Here's how to do it with the default firewall in Windows XP, Vista, 7 and Mac OS X.
  • Something is wrong with our server. If you have tried all of the above and PRAMS still can't connect, post in this forum or PM a member of staff and we will do our best to solve the problem.

  • Like 1

Share this post


Link to post
Share on other sites

I'm trying to find out my proxy information - we use mozilla - and I'm having no luck so far :(

Share this post


Link to post
Share on other sites

You'd think so wouldn't you, there is nothing in my LAN except port 80. I've disabled everything and hoping that will work. I've posted in the mozilla forum, maybe wondering whether to try it on a different computer.

Share this post


Link to post
Share on other sites

It didn't like my laptop so now have installed it on the other computer - tres excited now!!! Thank you for your help though - it's amazing how quick you are at replying back and helping to rectify the issues - if only all companies etc were like you the world would be a much smiler place!!

  • Like 3

Share this post


Link to post
Share on other sites

Thanks. I was actually in the process of replying to your previous post when this one appeared, glad you've got it sorted now.

Share this post


Link to post
Share on other sites

Hi

We are having problems with the io error when launching Prams. The error occours when downloading News, if we select not to automatically check for updates we can launch and use Prams. We can then read news from within Prams and follow all the links etc.

 

We access the Internet via a proxy server and also use Netsweeper Web Filtering which we have access to but need the specific urls for each address that Prams uses so we can try and allow access to, not sure if this is the problem but worth a try.

 

Thanks

Share this post


Link to post
Share on other sites

Hi

Having problems when trying to update, this worked fine when we first installed Prams before half term, 2 weeks ago when using same proxy settings? See attachment.

 

Got IT to check all settings etc

 

Thanks

io error.doc

Share this post


Link to post
Share on other sites
View download stats
  1. io error.doc (15)

Is PRAMS set to automatically detect your proxy or have you entered the details manually?

Share this post


Link to post
Share on other sites

Hi Matt,

I have been using PRAMS for the past 18 months and although one or two 'teething' problems, with success, but today when i have tried to access Prams the error io connection is coming up?

Gb

We have had a new wireless box connected couple of weeks ago, and not tried to get on prams since, so is this a reason?...sorry not very tech skilled!

Share this post


Link to post
Share on other sites

Hi meridian,

 

Did you previously have to configure the proxy server settings in PRAMS?

Share this post


Link to post
Share on other sites

Hi Matt

Not sure exactly, when set up Prams originally, don't think that I did, but long time ago!

Share this post


Link to post
Share on other sites

Hi Matt,

will follow the guidelines you posted above on the 5th Nov and see what can sort out my end,

fingers crossed this will be successful ^_^

Share this post


Link to post
Share on other sites

I can get it to work at home but even when i put the proxy settings in my hand it's still has IO exception... Really getting annoyed with it now.

Share this post


Link to post
Share on other sites

Hi pinkcustard, welcome to the forum and congratulations on making your first post.

 

Have you been able to get PRAMS to work before in your setting or is this the first time you've tried it?

Share this post


Link to post
Share on other sites

I also have this problem. If I change the options to not check for updates it will launch at home but not at work through a proxy server. It worked all last year, it even worked last week at school and at home! I am getting really worried as we are a nursery school and PRAMS is the only thing we use to record children's progress. I think that I may need to give up and find an alternative. I have been singing the praises of PRAMS to other schools because when it works it is excellent but if it is unreliable then it is no use to me. Can anybody help please?

Share this post


Link to post
Share on other sites

Hi OgleyHay, welcome to the forum and congratulations on making your first post.

 

Since starting this topic I have found that there are quite a few people who are having problems with proxy servers. Rest assured that I am working on solving it but it is quite a tricky thing to do. Since everyone's network is set up differently, I can't test things very easily.

 

You could try changing the options in the PRAMS launcher so that it is not set to automatically detect proxy server settings, as I have found out that this will not work a lot of the time. There should be an update sometime early next week that will hopefully sort things out.

Share this post


Link to post
Share on other sites

I have entered the proxy details which are correct although when i try to update the plugins they all fail. The news ticker works.

When logged in locally it all works fine. Just when on the network it wont install plugins.

Share this post


Link to post
Share on other sites

Hi prattnic, welcome to the forum and congratulations on making your first post.

 

I think the problem here is your network installation, since you're able to get through the proxy server to get the list of plugins to download in the first place. When PRAMS is installed on a network it needs to be configured differently to avoid various problems. By default PRAMS stores its configuration files and plugins in the a subfolder of the user's %APPDATA% folder, which causes problems with network installations. You can manually configure PRAMS to use a specific folder. Create a folder in a shared network folder for this purpose, it will need to have write access for all PRAMS users. Next you need to install a configuration file in the PRAMS installation folder (next to PRAMS2.exe). Here's an example configuration file. You need to change the path on the first line to point to the folder you just created and the path on the second line to the subfolder "prams_framework_config" in the folder you just created.

 

This will force that PRAMS installation to use a single, fixed location for configuration files and plugins for all users. It should solve your problems with installing plugins by making the plugins folder accessible.

Share this post


Link to post
Share on other sites

I've just released an update that will hopefully improve things for those of you suffering from proxy server woes. You can download it from the resource library here.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, I have been trying all morning (unsuccessfully) to enable PRAMS on the pre-school computer. I have put it on the firewall to be accepted and I have tried several port numbers for the proxy server (this was guess work as there is no information stored on our computer in the LAN section as the guide said there should be) I am getting very frustrated as this programme has been recommended and yet I cannot even get it to install. Any suggestions would be great before I just give up and look for something else!

Share this post


Link to post
Share on other sites

Hi dunholmeps, welcome to the forum and congratulations on making your first post.

 

The fact that there's no proxy settings in Internet Options suggests that you're not using a proxy server, otherwise your web browser would not be able to get through it. On the other hand, if you are using a proxy server, guessing the port number is unlikely to work as there are over 65000 possibilities. I suggest asking whoever set up your network whether it uses a proxy server and, if so, what the correct details are.

Share this post


Link to post
Share on other sites

Hi, thanks for the speedy reply! We are a committee run Pre-school and so no-one knows who set the system up as it was several committees ago. Is there anything else I can do or should I just give it up as a bad job?

Share this post


Link to post
Share on other sites

I'm inclined to think that you don't have a proxy server, these are usually imposed on settings by local authorities. I'd like to connect to your computer to have a look and see if I can figure out what's going wrong. You'd be able to see what I'm doing and disconnect ay any time. If that' OK with you, let me know and I'll send you the details.

Share this post


Link to post
Share on other sites

That would be great if you don't mind?! I'm not overly computer literate as I'm sure you can tell - all help is greatfully recieved!

 

Thanks

Share this post


Link to post
Share on other sites

I've sent you the details in a PM, use the envelope button near the top right of this page to read it.

Share this post


Link to post
Share on other sites

Hello Matt,

 

We are getting a connection failed error, and it will not update or attach to prams server.

I have installed the latest version v2.2 , but it is still not connecting.

Running through a cachepilot proxy, details of which we have entered manually.

 

Please help

Share this post


Link to post
Share on other sites

×